Case 78836: SurePost not printing properly
Incident Report for ShipRush
Resolved
This incident has been resolved.
Posted Jun 08, 2020 - 14:14 PDT
Monitoring
Users should now be able to process SurePost labels successfully. If you are having trouble with an older label, try voiding and re-shipping it. Please reach out to ShipRush support if you continue to have trouble with label printing.
Posted Jun 08, 2020 - 08:48 PDT
Investigating
Many users trying to ship UPS SurePost via ShipRush Web may be experiencing issues receiving or printing their labels this morning. We are working to resolve this issue as soon as possible, and will update here once we have more to share.
Posted Jun 08, 2020 - 08:10 PDT
This incident affected: Carrier Functionality.