Case 74499 - Connectivity issues with ShipRush Web
Incident Report for ShipRush
Resolved
This incident has been resolved.
Posted Jun 24, 2019 - 11:49 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2019 - 11:32 PDT
Investigating
We are aware of the issue affecting some users, causing timeouts, delays, or errors when shipping USPS. We are investigating and will update here when we know more.
Posted Jun 24, 2019 - 10:53 PDT
This incident affected: Carrier Functionality.