Case 77677: Chrome: Login Page Blinks But Doesn't Open ShipRush Web on Sign In
Incident Report for ShipRush
Resolved
We believe this issue to be fully resolved. If you've tried the steps above, and are still having difficulty, please reach out to ShipRush Support.
Posted Mar 13, 2020 - 10:15 PDT
Monitoring
A fix for this issue was rolled out last evening that we do believe has resolved the Chrome Security log in issue.

If you are still experiencing trouble accessing my.ShipRush.com through a Chrome browser, please try these steps:

-Update to the latest version of Chrome. This can be done by going to Help > About Google Chrome. It should update automatically, or have a button for you to update at that point.
-Clear out your Chrome Cache (Cookies/History "From The Beginning of Time").
-Do a full restart your shipping computer

If you're still having trouble at that point, please reach out to ShipRush support. Thank you.
Posted Mar 11, 2020 - 11:08 PDT
Update
Unfortunately the fix did not pass all tests successfully. Development is still hard at work on this concern. Please continue to use alternative browsers, and we will update here when we have more to share.
Posted Mar 04, 2020 - 11:46 PST
Update
A fix is now in testing, and as long as it passes it should go live tomorrow (3/4). Thank you for your patience.
Posted Mar 03, 2020 - 12:16 PST
Identified
The issue has been identified, and development is actively working on a fix. Please continue to use alternative browsers until we have this fully resolved.
Posted Mar 02, 2020 - 15:15 PST
Investigating
Some users may be experiencing difficulty logging into My.ShipRush.com after updating the Chrome browser. We are aware of the issue and are working to resolve it now.

Please be aware this is specific to Chrome, so you can keep shipping by using FireFox, Edge or Safari until we sort out this issue. We will update here once there is more to share.
Posted Mar 02, 2020 - 12:13 PST
This incident affected: ShipRush Web.