ShipRush Toolbox returning SSL/TLS Secure Channel error for WIndows 7
Incident Report for ShipRush
Resolved
This incident has been resolved.
Posted Jan 15, 2024 - 09:52 PST
Monitoring
Development has found a stop-gap change that should help this issue. Windows 7 is still not a supported OS, so please update as soon as you are able to avoid similar trouble in the future.
Posted Jan 15, 2024 - 08:13 PST
Identified
Hello,

Many users who were still using Windows 7 have discovered today that they are receiving an error when trying to use the My.ShipRush.com toolbox. Notices were sent out about this in Fall of last year, but to clarify: Windows 7 is lacking some of the modern security options of later systems, resulting in that error. Microsoft has stopped support of WIndows 7 on January 14, 2020, which is why the required update is missing, and also why it won't be added into Windows 7.

Because of that, to use the My.ShipRush.com toolbox, you will need to be running Windows 10 or 11 to connect properly, there will not be a work-around to this issue.

For those who are not able to update now, please go to your My.ShipRush.com printer settings and adjust the printer type to be Laser/Inkjet. You can also use the More > Ship (Print to PDF) option to get a download of the label.

Thank you,

-ShipRush Support
Posted Jan 15, 2024 - 08:06 PST
This incident affected: ShipRush Web.