Declared Value Server Error: ... (503) Server Unavailable. Case 994909
Incident Report for ShipRush
Resolved
This issue has been resolved.
Posted Feb 27, 2024 - 15:18 PST
Identified
There is a server issue with our insurance provider, causing various errors including Server Unavailable when trying to process a shipment with a declared value set. This is being investigated now, and we will post updates here as they become available.
Posted Feb 27, 2024 - 15:13 PST
This incident affected: ShipRush Web.