General slowness in ShipRush Web
Incident Report for ShipRush
Resolved
This slowness issue should now be resolved. Please reach out to support if you continue to see any difficulty.
Posted May 22, 2023 - 09:06 PDT
Investigating
Many users are experiencing slowness when trying to access My.ShipRush.com, or use related systems. We apologize for the difficulty, our development team is looking into the issue now, and we hope to have a resolution soon.
Posted May 22, 2023 - 08:38 PDT
This incident affected: ShipRush Web.