ShipRush Web - Desktop Toolbox Maintenance
Incident Report for ShipRush
Resolved
This incident has been resolved.
Posted Sep 09, 2020 - 11:19 PDT
Monitoring
There is a Planned Maintenance taking place currently for the ShipRush Desktop Toolbox, which will conclude at 11:30p PST (2:30p EST). If you are on an older version of the Toolbox, this will prevent you from having access to printers, scales, and clipboard shipping.

Please visit https://shiprush.com/2020toolboxupdate/ for more information on the required update, and how to run it. If you can't update this moment, please wait until 11:30p PST to resume shipping, and plan to update the toolbox as soon as is convenient.
Posted Sep 09, 2020 - 10:20 PDT
This incident affected: ShipRush Web.