Case 76992 - ShipRush Support Phones unavailable
Incident Report for ShipRush
Resolved
We apologize for the trouble, phone support is again available.
Posted Jan 13, 2020 - 09:41 PST
Identified
We apologize for the trouble, due to a technical failure our main support line is currently unavailable. Chat support is available on www.ShipRush.com and My.Shiprush.com, and email support is available at Info@Shiprush.com. We will update here as soon as we have more to share.
Posted Jan 13, 2020 - 08:43 PST
This incident affected: ShipRush Web.