EasyPost Direct accounts returning errors on Rate and Ship
Incident Report for ShipRush
Resolved
EasyPost has reported the issue has been resolved, and their engineering team is monitoring the situation. Please refer to https://www.easypoststatus.com/ for further updates, thank you.
Posted Feb 27, 2024 - 13:41 PST
Identified
Many users with personal EasyPost accounts are receiving errors when rating and shipping. EasyPost is aware of the issue and working to resolve it now. We will provide what updates we can here, but please refer to their status page for additional details:

https://www.easypoststatus.com/
Posted Feb 27, 2024 - 13:24 PST
This incident affected: Carrier Functionality.