UPS Server Outage
Incident Report for ShipRush
Resolved
UPS systems should again be fully operational.
Posted Jul 25, 2024 - 15:19 PDT
Identified
The UPS Server outage has returned. It does appear to be tied to Address Validation, so disabling that in settings may help, but some shipments are failing regardless of settings.

UPS Support is aware of the problem and working to resolve it now.
Posted Jul 25, 2024 - 12:45 PDT
This incident affected: Carrier Functionality.