ShipRush Web - "There was a problem" loading the page
Incident Report for ShipRush
Resolved
This incident has been resolved.
Posted May 29, 2023 - 09:54 PDT
Update
We believe this issue is resolved, and that all users should again have access to ShipRush Web. Development is continuing to monitor for any further issues.
Posted May 24, 2023 - 10:24 PDT
Monitoring
Most users should again be able to access My.ShipRush.com. Some remaining errors are still under investigation by development.
Posted May 24, 2023 - 09:45 PDT
Identified
Improvements have been made, but development continues work to address this stability issue.
Posted May 24, 2023 - 08:19 PDT
Investigating
Many users are experiencing an error when trying to access My.ShipRush.com, typically a yellow bar that said 'something went wrong'. Development is working on this issue now, we apologize for the trouble.
Posted May 24, 2023 - 07:35 PDT
This incident affected: ShipRush Web.