ShipRush Case 72117 - ShipRush Web Slowness / Unresponsiveness
Incident Report for ShipRush
Resolved
The connectivity issue should now be fully resolved.
Posted 3 months ago. Apr 08, 2019 - 10:38 PDT
Investigating
We are currently investigating the slowness/timeout issues some users are experiencing when accessing My.ShipRush.com. We will update here as soon as there is more to share.
Posted 3 months ago. Apr 08, 2019 - 09:42 PDT
This incident affected: ShipRush Web.