Case 79092 - The Load Balancer was unable to handle this request
Incident Report for ShipRush
Resolved
This issue has long since been resolved, we apologize for the delay in notification.
Posted Jul 01, 2020 - 07:59 PDT
Investigating
Many users are experiencing this error when rating and shipping. Development is working to resolve this ASAP - we will update here once we have more to share.
Posted Jun 30, 2020 - 17:27 PDT
This incident affected: ShipRush Web and Carrier Functionality.