Case 79435 - Unable to access My.ShipRush.com, Bad Request Errors, Timeout errors
Incident Report for ShipRush
Resolved
This issue should now be fully resolved for all users. If you continue to run into trouble shipping, please reach back out to ShipRush Support.
Posted Jul 29, 2020 - 14:09 PDT
Monitoring
A fix has been rolled out, and Development is monitoring the website now. Users are reporting being able to ship again, but there still may be lingering errors for the next 10-15 minutes.
Posted Jul 29, 2020 - 13:23 PDT
Identified
Development has identified the issue, and is working to have it resolved as soon as possible.
Posted Jul 29, 2020 - 12:41 PDT
Investigating
Many users are currently unable to access My.ShipRush.com, reporting various errors including "Bad Request". Development is aware of the issue and is working to have it resolved ASAP. We will update here as soon as there is more to share.
Posted Jul 29, 2020 - 12:15 PDT
This incident affected: ShipRush Web.