EasyPost Server Outage
Incident Report for ShipRush
Resolved
EasyPost confirms the outage has now passed, please reach out to ShipRush support if you continue to see errors.
Posted Mar 25, 2020 - 12:36 PDT
Monitoring
One of our USPS Providers, EasyPost, is currently experiencing server outages, which is causing errors for USPS shipping inside of ShipRush. Please visit: https://www.easypoststatus.com/ for updates on this outage
Posted Mar 25, 2020 - 09:28 PDT
This incident affected: Carrier Functionality.