INC-2131509 - Phone Support call quality issues
Incident Report for ShipRush
Resolved
All phone quality issues are now resolved, we apologize for the inconvenience.
Posted Feb 03, 2020 - 13:55 PST
Identified
We are currently experiencing issues with our phone systems, causing dropped calls and poor sound quality. Phone support is still available, but we suggest for clarity to reach out to our other avenues:

Chat Support: www.ShipRush.com - use the chat box in the lower right corner.
my.ShipRush.com - Use the "Support" button in the lower left corner of the main screen.

Email Support: Servicedesk@Descartes.com

We will update here once the phone concern has been resolved.
Posted Feb 03, 2020 - 10:52 PST
This incident affected: ShipRush Web.