ShipRush Case 72452 - My.SR cannot be accessed
Incident Report for ShipRush
Resolved
This issue should now be fully resolved. Please contact support if you continue to have difficulty accessing ShipRush Web.
Posted 6 months ago. Apr 24, 2019 - 12:40 PDT
Investigating
A few users are experiencing issues accessing ShipRush Web, getting errors or a gray screen. We are aware of the issue and are investigating it now. We will update here when there is more to share.
Posted 6 months ago. Apr 24, 2019 - 11:58 PDT
This incident affected: ShipRush Web.