71495: SRWeb: PB error: Internal error occurred
Incident Report for ShipRush
Resolved
Pitney Bowes reports this issue should now be fully resolved.
Posted 7 months ago. Mar 11, 2019 - 16:01 PDT
Investigating
Pitney Bowes is aware of the issue and is working to resolve ASAP. We will post updates here.
Posted 7 months ago. Mar 11, 2019 - 15:25 PDT
This incident affected: Carrier Functionality.