ShipRush Weekly Maintenance Window
Incident Report for ShipRush
Resolved
This incident has been resolved.
Posted Aug 15, 2020 - 23:00 PDT
Monitoring
ShipRush Web is undergoing routine maintenance between 9:00pm Pacific Time and 11:00pm Pacific . Users will be unable to access My.ShipRush.com or access to ship USPS during those hours. Thank you for your patience.
Posted Aug 15, 2020 - 21:00 PDT