Case 74661 - Slowness, or errors when shipping USPS
Incident Report for ShipRush
Resolved
This issue should now be resolved. Reload ShipRush and try your shipment again. If you continue to have difficulty, please reach out to support.
Posted Jul 05, 2019 - 08:15 PDT
Investigating
We are aware of this issue and are investigating. We will update here once it has been resolved.
Posted Jul 05, 2019 - 08:05 PDT
This incident affected: ShipRush Web.