Amazon Orders slow to update
Incident Report for ShipRush
Resolved
This issue should be resolved now, but please be aware there may be future delays with Amazon Web services during peak traffic hours.
Posted Nov 24, 2021 - 17:11 PST
Identified
Many Amazon.com users are experiencing delays in both the update of shipped orders, and the download of very new orders. This is due to server difficulty on the Amazon side - they are aware of the problem and working to resolve it now.

Please be aware, ShipRush will automatically retry to update orders after a failed attempt. We suggest that you check your orders again later on this evening.
Posted Nov 24, 2021 - 13:34 PST
This incident affected: Ecommerce connectivity.