Reports of slowness on ShipRush Web
Incident Report for ShipRush
Resolved
This has been resolved. If you continue to see an issue of this kind, log out, close the browser tab, and log back in.
Posted 11 months ago. Jul 10, 2018 - 09:54 PDT
Update
We expect the issue to be resolved in the next 10-15 minutes.
Posted 11 months ago. Jul 10, 2018 - 09:16 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 11 months ago. Jul 10, 2018 - 09:06 PDT
This incident affected: ShipRush Web.