ShipRush Desktop for Order Manager - Issues adding webstores or new ShipRush Discount Postage account
Incident Report for ShipRush
Resolved
This incident has been resolved.
Posted Jun 21, 2021 - 16:35 PDT
Monitoring
A recent security update to My.ShipRush.com has caused the desktop Order Manager version of ShipRush to have browser formatting issues when adding Webstores or new USPS shipping accounts. To resolve this issue, simply fully exit ShipRush, and update to the latest version (12.5.14.6463) found here: https://shiprush.com/downloads/

Please reach out to support if you continue having any issues after the update.
Posted Jun 17, 2021 - 12:12 PDT
This incident affected: ShipRush Web and Ecommerce connectivity.