ShipRush Case 72952 - USPS Outage - Carrier Did Not Respond when rating/shipping
Incident Report for ShipRush
Resolved
This outage has been resolved, users should be able to ship again without issue.
Posted about 1 month ago. May 17, 2019 - 14:51 PDT
Investigating
We are aware of this issue affecting some users, and are investigating now. We will post updates here as they become available.
Posted about 1 month ago. May 17, 2019 - 14:20 PDT
This incident affected: Carrier Functionality.