Case 79065 - USPS Error: Missing required data to get rates
Incident Report for ShipRush
Resolved
This issue should now be fully resolved.
Posted Jun 26, 2020 - 14:52 PDT
Update
Please note, the temporary fix put in place may cause some shippers to see an "SUSPENDED" error on shipping. The most common cause for this is shipping with a Return address that is not a physical location, such as a PO Box. USPS Policy requires a physical address be on record for shipping accounts, so here are the steps to re-register your account, to resolve this error:

- Navigate to Settings and click "Add Shipping Account" at the top
- Select ShipRush Discount Postage from the list, and follow the prompts.
- When asked for an address, please provide a physical location such as your home address. A PO box will not help resolve this error.
- Once the account has been added, you can update your return address to be the PO box.
- Now, delete your old ShipRush Discount Postage Account. The new and old share a balance, and no history will be lost.

If you continue to have difficulty, please reach out to ShipRush support and they can assist with this process.
Posted Jun 26, 2020 - 12:22 PDT
Monitoring
We've identified the issue and made a change that should allow USPS users to ship again.
Posted Jun 26, 2020 - 10:34 PDT
Investigating
We are aware of this issue affecting USPS shippers and are currently investigating. We will post updates here as soon as they become available.
Posted Jun 26, 2020 - 10:28 PDT
This incident affected: Carrier Functionality.