ShipRush Desktop Toolbox Maintainence
Incident Report for ShipRush
Resolved
This maintenance for today has completed. If you have not yet updated your toolbox, please do so as soon as possible.
Posted Aug 27, 2020 - 12:52 PDT
Monitoring
There is a Planned Maintainence taking place currently for the ShipRush Desktop Toolbox, which will conclude at 1:00p PST (4p EST). If you are on an older version of the Toolbox, this will prevent you from having access to printers, scales, and clipboard shipping.

Please visit https://shiprush.com/2020toolboxupdate/ for more information on the required update, and how to run it. If you can't update this moment, please wait until 1:00p PST to resume shipping, and plan to update the toolbox as soon as is convenient.
Posted Aug 27, 2020 - 11:03 PDT
This incident affected: ShipRush Web.