Case 77958: SRWeb: Timeouts, slow loading, errors loading
Incident Report for ShipRush
Resolved
This incident has been resolved.
Posted Mar 23, 2020 - 10:54 PDT
Monitoring
We believe this issue to have passed. Please reach out to support if you continue to have connectivity errors or other concerns.

Thank you.
Posted Mar 23, 2020 - 09:32 PDT
Investigating
Many users may be experiencing errors in both Desktop and Web versions of ShipRush, getting timeouts or errors when trying to load. We are investigating this issue now - many users are finding they are able to ship if they try reloading their page, but may have slow shipping.

We will update here when we have this resolved.
Posted Mar 23, 2020 - 07:54 PDT
This incident affected: ShipRush Web.