ShipRush Chat Support currently unavailable
Incident Report for ShipRush
Resolved
Chat support is again available, during normal business hours.
Posted Nov 16, 2020 - 12:03 PST
Identified
The support chat client we use is experiencing some connectivity issues this morning which are currently being addressed. Phone support will be available from 8:30-5:00 PST at (206)812-7874, and email support is still available at Servicedesk@Descartes.com now. We apologize for the inconvenience, and hope to have this resolved soon.
Posted Nov 16, 2020 - 07:16 PST
This incident affected: ShipRush Web.