Case 76926: Errors using ShipRush Discount Postage
Incident Report for ShipRush
Resolved
This issue should now be fully resolved, please contact support if you continue to run into errors using ShipRush.
Posted Jan 08, 2020 - 09:20 PST
Investigating
Many users may be experiencing errors when trying to purchase postage, or in certain cases when trying to ship. We are aware of the issue and are working to resolve it ASAP. We will update here once it has been fully resolved.
Posted Jan 08, 2020 - 08:21 PST
This incident affected: Carrier Functionality.