Case 78296: Insufficient funds error on shipping, despite having available funds.
Incident Report for ShipRush
Resolved
This incident has been resolved.
Posted Apr 20, 2020 - 22:41 PDT
Identified
A tentative fix has been put into place which may allow some users to ship again. We are still working on a full resolution.
Posted Apr 20, 2020 - 12:05 PDT
Investigating
We are aware and investigating this issue affecting all USPS shippers, and expect to have it resolved soon. Please watch this page for updates.
Posted Apr 20, 2020 - 11:56 PDT
This incident affected: Carrier Functionality.